Getting Rails, Sphinx, MySQL working on Snow Leopard

Had to switch to the 64-bit version of MySQL. Then I needed to re-install the MySQL gem as follows:
env ARCHFLAGS="-arch x86_64" gem install mysql -- --with-mysql-config=/usr/local/mysql/bin/mysql_config
For Sphinx, I had to compile with the following commands:
LDFLAGS="-arch x86_64" ./configure --prefix=/usr/local --with-mysql=/usr/local/mysql
make
sudo make install
Check out this website for more info.

Update: Use the 32-bit version of MySQL if you’re still on Leopard. Apparently the Ruby interpreter is 32-bit on Leopard and 64-bit on Snow Leopard. Grr.